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Legal notice 
Copyright and trademark information relating to this product release.  

Copyright © 2000–2021 SDL as part of the RWS Holdings Plc group of companies ("RWS Group"). 

 SDL means SDL Limited and its subsidiaries and affiliates. All intellectual property rights contained herein 
are the sole and exclusive rights of SDL. All references to SDL shall mean SDL Limited and its subsidiaries 
and affiliates details of which can be obtained upon written request.  

All rights reserved. Unless explicitly stated otherwise, all intellectual property rights including those in 
copyright in the content of this website and documentation are owned by or controlled for these purposes 
by SDL. Except as otherwise expressly permitted hereunder or in accordance with copyright legislation, the 
content of this site, and/or the documentation may not be copied, reproduced, republished, downloaded, 
posted, broadcast or transmitted in any way without the express written permission of SDL.  

Trados Studio is a registered trademark of SDL. All other trademarks are the property of their respective 
owners. The names of other companies and products mentioned herein may be the trademarks of their 
respective owners. Unless stated to the contrary, no association with any other company or product is 
intended or should be inferred.  

This product may include open source or similar third-party software, details of which can be found by 
clicking the following link: “Acknowledgments”. 

Although RWS Group takes all reasonable measures to provide accurate and comprehensive information 
about the product, this information is provided as-is and all warranties, conditions or other terms 
concerning the documentation whether express or implied by statute, common law or otherwise 
(including those relating to satisfactory quality and fitness for purposes) are excluded to the extent 
permitted by law.  

To the maximum extent permitted by law, RWS Group shall not be liable in contract, tort (including 
negligence or breach of statutory duty) or otherwise for any loss, injury, claim liability or damage of any 
kind or arising out of, or in connection with, the use or performance of the Software Documentation even 
if such losses and/or damages were foreseen, foreseeable or known, for: (a) loss of, damage to or 
corruption of data, (b) economic loss, (c) loss of actual or anticipated profits, (d) loss of business revenue, 
(e) loss of anticipated savings, (f) loss of business, (g) loss of opportunity, (h) loss of goodwill, or (i) any 
indirect, special, incidental or consequential loss or damage howsoever caused.  

All Third Party Software is licensed "as is." Licensor makes no warranties, express, implied, statutory or 
otherwise with respect to the Third Party Software, and expressly disclaims all implied warranties of non-
infringement, merchantability and fitness for a particular purpose. In no event will Licensor be liable for 
any damages, including loss of data, lost profits, cost of cover or other special, incidental, 
consequential, direct, actual, general or indirect damages arising from the use of the Third Party 
Software or accompanying materials, however caused and on any theory of liability. This limitation 
will apply even if Licensor has been advised of the possibility of such damage. The parties 
acknowledge that this is a reasonable allocation of risk.  

Information in this documentation, including any URL and other Internet website references, is subject to 
change without notice. Without limiting the rights under copyright, no part of this may be reproduced, 
stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, 
mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written 
permission of RWS Group. 
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1 About this Quick Start Guide 

Who is this guide for and what does it cover? 

This guide is for project managers. It focuses on the project lifecycle, starting with creating a project and then 
managing that project through the use of packages. 

Note: For information about online workflows using Trados GroupShare Project Server, see to the 
videos and information in the Trados Studio Help available at: https://docs.rws.com/TradosStudio . 

How to use this guide 

 

 You can use the sample files to complete the exercises. Each exercise builds on the 
last so if you are using the sample files you need to follow through the instructions 
step-by-step. 

 This symbol indicates there are sample files available to complete the exercise and 
their location. The paths specified are based on a Microsoft Windows 10 or later 
operating system. 

Note This indicates that there is a tip providing additional information on the task you are 
performing. 

Keyboard 

shortcuts 
This symbol indicates that there is an important piece of information you need to 
know for the task you are performing. Any keys that you need to press on your 
keyboard are displayed in the following font: Ctrl+Enter. 

 

 

Cloud references 

In this guide, the term "cloud" covers all RWS product offerings powered by RWS Language 
Cloud: 

 Trados Live Essential 

 Trados Live Team 

 Trados Enterprise (formerly RWS Language Cloud Translation Management) 

However, all the examples illustrate working with cloud projects using a cloud account with a 
Trados Live Essential subscription. 

Other information sources 

Here are some other sources of information you can access: 

 Trados Studio 2021 SR2 Help 

 Trados GroupShare Help 

 Trados GroupShare Installation Guide 

 Trados Studio 2021 Migration Guide 

https://docs.rws.com/TradosStudio
https://docs.rws.com/TradosStudio2021
http://docs.rws.com/TradosGroupShare
https://docs.rws.com/TradosGroupShare/InstallationGuide
https://docs.rws.com/TradosStudio2021/MigrationGuide
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 Translation Memory Management Quick Start Guide 

 Trados Live Essential documentation 

 Trados Live Team documentation 

 Trados Enterprise documentation 

 

2 About Trados Studio 

Trados Studio enables organizations to effectively manage all aspects of their translation 
projects. Trados Studio incorporates project management and computer-aided translation 
(CAT) tools for use by project managers, translators, editors, proofreaders and other language 
professionals. These tools are provided through a highly customizable user interface and it is 
easy to add on features from the RWS AppStore. 

 

3 Default Language Pair Settings 

3.1 Language pairs 

A language pair is used to store settings relating to translation from a specific source language 
into a specific target language. Resources and options are typically configured for use across all 
language pairs to which they apply. Multilingual resources, such as termbases and server-based 
translation memories, may apply to more than one language pair. Bilingual resources, such as 
file-based translation memories, only apply to a specific language pair. 

You may want to set up these default settings prior to translating documents. This allows you to 
use the same settings and resources for all your translations. For example, you may want to 
specify which translation memory, termbase and other resources to use to translate from 
English to German. 

For example, if you always have translation projects that are translated from English to German, 
you may want to specify which translation memory, termbase and other resources to use. 

3.2 Options dialog 

You can define default settings for use in your translation projects in the Options dialog. When 
you define settings here, it automatically updates the default project template which you can 
then select when creating your project. The default project template is stored in: 
Documents\Studio 2021\Projects\Samples\Project Templates\Default.sdltpl 

 Alternatively, you can use project templates to define your settings for customers for whom 
you need to create several projects. Select File > Setup > ProjectTemplate from the Ribbon to 
create a template. 

https://docs.rws.com/TradosStudio2021/TranslationMemoryManagementQSG
https://docs.rws.com/TradosLiveEssential
https://docs.rws.com/TradosLiveTeam
https://docs.rws.com/TradosLiveTeam
https://docs.rws.com/LanguageCloudTMS
https://docs.rws.com/LanguageCloudTMS


 

 

 

 

 7 

3.3 All Language Pairs 

Typically, you configure translation resources (even if they are bilingual) and edit settings at the 
All Language Pairs level. The settings then apply to all language pairs and the translation 
resources apply to the all language pairs to which they are relevant. 

For example: 

 If you select a multilingual server-based translation memory at the All Language Pairs 

level that contains English to German and English to French language pairs, this 
translation memory is automatically selected for English to German and English to 
French projects. 

 If you change the minimum match value to 65% at the All Language Pairs level, it will 
apply to all language pairs. 

 

Individual exceptions to these settings can be defined for each language pair. For example, if 
you wanted the English to German language pair to have a different minimum match value, you 
could change it at the individual language pair level. 

 

3.4 Resources 

You can select the following resources for a language pair: 

 

Resource Description 
Translation memories  The Trados Studio translation memory file-based format is *.sdltm. You can 

use translation memories from any version of Trados Studio 2009 and later. If 
you have a translation memory from a previous version of SDL Trados or 
SDLX, refer to the Trados Studio 2021 Migration Guide for details of how to 
upgrade the translation memory to the current format. 

https://docs.sdl.com/TradosStudio2021/MigrationGuide
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You can also connect to server-based translation memories from Trados 
GroupShare 2017-2020. 
To connect to WorldServer 11.x and 10.4.5 Live TM, go to the Add-ins tab > 
RWS AppStore and install the free WorldServer Compatibility Pack for 
Studio. 

Termbases Trados Studio 2021 is compatible with file-based termbases created in 
MultiTerm 2017 and later. In addition, you can use the following legacy 
termbase formats: 

 MultiTerm 2007 (version 7.5) and previous 7.x releases 
 MultiTerm iX (version 6.x). 

When you open legacy termbases, they are automatically upgraded to 
MultiTerm 2021, *.sdltb format. You can also connect to sever-based 
termbases in Trados GroupShare 2017 and later. 
A convenient way of adding terminology assets to your project is using 
termbases in your Language Cloud account. If you have these configured in 
your Language Cloud account, you can use them just like any other termbase 

AutoSuggest 
dictionaries  

AutoSuggest editing is an important feature which can be used to speed up 
manual translation. AutoSuggest monitors what you are typing. After you 
have typed the first few characters of a word, AutoSuggest presents you with 
a list of suggested words and phrases from the translation memory in the 
target language that start with the same characters. You can use the 
following as sources for AutoSuggest: 

 AutoSuggest dictionaries - create a new or select an existing 
AutoSuggest dictionary created by yourself or another user. This 
dictionary contains words and phrases extracted from translation 
memories (*.sdltm) or *.tmx files. 

 A MultiTerm termbase selected in your project. 
 

 AutoText entries - create a list of words and phrases manually by 
typing them into Trados Studio. 

 

The AnyTM translation providers for local TMs, server-based TMs and machine translation 
providers allow you to leverage translations from TMs with different source or target language 
than the ones you have set in your project. 

3.5 Defining your default language pair settings 

Before starting to translate local projects, you may want to set up default language pair 
settings. This allows you to use the same settings and resources for all your local translations. 
For example, you may want to specify which translation memory, termbase and other resources 
to use to translate local projects from English to German. 

About this task 

Follow these instructions to set up your default translation memories, termbases and 
AutoSuggest dictionaries for translating from English (United States) to German (Germany). 
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Note: These settings should be defined at the All Language Pairs level where possible. 

 

You can follow the same procedure for setting up default resources for other language pairs. In 
this example, you will use the sample project in Trados Studio. Once you are familiar with these 
steps, you can then use them to specify your own default resources for all language pairs with 
which you are working. 

Procedure 

1. Select File > Options from the Ribbon. The Options dialog is displayed. 

2. Select Language Pairs > All Language Pairs > Translation Memory and Automated 
Translation from the navigation tree. 

3. On the Translation Memory and Automated Translation page, you can select file-based 
and server-based translation memories. Select Use>File-based Translation Memory and 
browse for the sample translation memory file. 

…Documents\Studio2021\Projects\Samples\SampleProject\TMs\English-German.sdltm 

 If your setup does not include any default options for the language pair English (United 
States) - German (Germany), the Add Supported Language Pairs dialog is displayed. 
Select the check box next to the language pair and click OK. 

 

4. Select Language Pairs > All Language Pairs > Termbases from the navigation tree. 

5. On the Termbases page, you can select MultiTerm termbases. Select Use>File-based 
MultiTerm Termbase and browse for the sample termbase file. 

…Documents\Studio2021\Projects\Samples\SampleProject\Termbase\Printer.sdltb 
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6. Select Language Pairs > English (United States) - German (Germany) > AutoSuggest 

Dictionaries from the navigation tree. 

Note: AutoSuggest dictionaries can only be defined at the individual language pair level. 
7. On the AutoSuggest Dictionaries page, you can select AutoSuggest dictionaries. Select 

Add and browse for the sample AutoSuggest dictionary file. 

…Documents\Studio2021\Projects\Samples\SampleProject\AutoSuggest\AutoSuggest_EN-

US_DE-DE.bpm 
 

 
8. Select OK to save your default settings. 
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These resources will now be used whenever you translate a document from English to German. 

 Click through the tree structure under All Language Pairs to define additional settings, such 
as minimum fuzzy match values and auto-substitution. Remember these settings will apply to 
all of the language pairs. If you want to specify settings that are only specific to the English to 
German language pair, do this under Language Pairs > (English United States) - German 
(Germany). 

 

4 Project concepts 

Before you create a project, review the project concepts below. 

Concept Description 
Language pairs A source language and a target language (language into which you are translating). 

Some resources and settings can be selected for use across all language pairs, for 
example termbases which are multilingual. Translation memories and AutoSuggest 
dictionaries are selected for a specific language pair as they are bilingual.  
For example, you could specify 70% as the minimum match value for fuzzy matches 
at the All Language Pairs level. This setting is then applied to every translation 
memory selected for each language pair.However, you can define the settings of a 
translation memory for all language pairs. 
 

Project All files are translated and managed as part of a project. A project may contain a 
single file or many files for translation into one language or several languages. It 
may also contain reference material, translation memories, termbases, AutoSuggest 
dictionaries and instructions for translators. 
Once a project has been created, the project manager can manage all aspects of 
project effort and monitor project progress using the project management tools in 
Trados Studio. 

Cloud project A cloud project is a translation project published on RWS Language Cloud, the 
translation productivity cloud from RWS. Cloud projects enable you to upload your 
TMs and termbases into your own secure cloud space and use them in Studio, along 
with cloud-based neural machine translation. 

Project package A project package is a file structure which contains all the files that need to be sent 
to a project team member to enable them to commence work on the project. For 
example, files to be translated or reviewed. Once the project package is created, you 
can send it by email, post on an FTP site or use any other method that you prefer to 
send it to the team member who will be working on the project files. This eliminates 
the need to send multiple files or multiple emails and enables all project information 
to be sent with project files in a coherent structure. 

Return packages A return package contains project files for which a specific manual task has been 
completed. For example, project files that have been translated or reviewed. It can 
also contain files for which further work needs to be completed. For example, a 
reviewer may want to return a translated file because of an incorrect translation 
which the translator needs to fix. When you create a return package it only includes 



 

 

 

 

 12 

the project files and not the translation memory, termbases or AutoSuggest 
dictionaries. 

PerfectMatch A PerfectMatch is a form of context match that compares updated source files to a 
corresponding set of existing bilingual documents rather than to a translation 
memory. Segment matches, known as PerfectMatches, are checked for context, that 
is, the surrounding entries are checked to ensure that they are the same. They are 
then extracted from the existing bilingual documents and transferred to the 
updated source files. Because the PerfectMatch segment matching process includes 
a check for context, PerfectMatch units typically need no further translation or 
editing during translation. 

Batch task A task is a process that is performed on an individual file or on a group of files (for 
example, an entire project). Batch tasks are performed by the system. For example, 
the Word Count batch task performs a word count for selected files and the word 
count results can be seen in the Trados Studio views and reports. Batch tasks can be 
put into a task sequence. All tasks in the sequence are performed (in the order in 
which they appear in the sequence) on all selected tasks. 

Task sequence A task sequence contains multiple batch tasks. When you run a task sequence, all 
tasks in the sequence are performed on all selected files: the tasks are performed in 
the order in which they appear in the sequence. A number of batch task sequences 
are provided for you and if you have the Professional version you can also create 
new ones. 

 

5 Creating projects 

Let us assume that you have been asked by a customer to translate a group of files from English 
to German. 

You translate the files as part of a local or a cloud project. Projects enable you to: 

 Produce translation analysis figures for viewing on screen in Trados Studio and in 
reports. 

 Convert project files to *.sdlxliff format. 

 Pre-translate project files by applying translations from translation memories. 

 Create a project translation memories. 

 If you do not select a task to be performed during project creation, you can perform that 
task after the project is created. For example, you may initially only want to analyze files 
when you create a project in order to get analysis figures to provide a quote for a customer. 

5.1 Creating a local project 

Create a translation project that you can work with and save locally, on your computer. 

About this task 

If you want to work with online projects instead, you can either: 
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 create cloud projects in the cloud, in your own secure cloud account. For information 
on cloud projects, see the Creating a cloud project chapter in this guide on page 31. 

 publish local projects on an Trados GroupShare server. For information on Trados 
GroupShare projects, see the videos and information in the Trados Studio Help. 

 save local projects to cloud. For information see the Save local projects to cloud in the 
Online Help. 

You can create new local projects either from Projects view > New Project > New Local Project 
or from the Welcome view where you can drag and drop your translation files. The Create a 
New Project wizard takes you through all the steps needed to create a translation project. 

Procedure 

1. Go to the Welcome view and drag the following files to translate on the Welcome 
screen: 

 SamplePhotoPrinter.doc 

 SamplePresentation.pptx 

 SecondSample.docx 

 TryPerfectMatch.doc 

…Documents\Studio2021\Projects\Samples\SampleProject\en-US 

2. In the Translate dialog, select Create new project. 

3. In the Use Settings from drop-down list on the first page of the Create a New Project 
wizard, if not already selected, select the Default project template. The default 
project template is updated with your default settings and the resources you 
defined in the Options dialog. 

…Documents\Studio 2021\Projects\Samples\Project Templates\Default.sdltpl 

https://docs.sdl.com/TradosStudio2021/
https://docs.sdl.com/SDLTradosStudio2021/
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4. Fill in a project name (e.g. Sample EN-DE). The project is automatically saved to the 

…Documents \Studio2021\Projects folder. Leave the default location. 

5. You are now ready to create your project with the One Step workflow. However, you 
can further customize the project settings by going through the other pages of the 
Create New Project wizard. 

 Click Finish to start the project creation and jump to the Summary page of the 
Create New Project wizard. 

 Click Next to further customize your project settings. 

 

5.2 Specifying project details 

Procedure 

1. In the General wizard page, fill in a Project Description. 
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2. Click Customers and create RWS as a customer. Then, select RWS from the 

Customer drop-down list. 

3. Click Next. 

 

 

5.3 Selecting translation memories 

In the Translation resources page, the translation memory you selected when you set up your 
default options is automatically selected for this project. 

About this task 

…Documents\Studio2021\Projects\Samples\SampleProject\TMs\English-German.sdltm 

Note: You can add multiple translation memories and also connect to automated translation 
servers (machine translation). 
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Procedure 

4. Add other translation resources to your project (see the Translating and reviewing 
documents guide). 

5. Click Next. 

 

5.4 Selecting termbases 

On the Termbases page, the termbase you selected when you set up your default options is 
automatically selected for this project. 

About this task 

…Documents\Studio2021\Projects\Samples\SampleProject\Termbase\Printer.sdltb 

Note: You can add multiple termbases 

https://doc.rws.com/TradosStudio2021/TranslatingAndReviewingQSG
https://doc.rws.com/TradosStudio2021/TranslatingAndReviewingQSG
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Procedure 

1. Add other termbases to your project (see the Translating and reviewing documents 
quick start guide). 

2. Click Next. 

5.5 Publish local projects on GroupShare 

You can publish your local project on Trados GroupShare to share it with other team members 
and assign work as necessary. 

Procedure 

1.  Select Publish project on Trados GroupShare. This publishes the project on Trados 
GroupShare. For information, refer to the videos and information in the Trados 
Studio 2021 Help. 

5.6 Reusing previously translated documents to apply PerfectMatch 

On the PerfectMatch page, you can select previously translated documents to be used for 
PerfectMatch. 

“PerfectMatch” on page 11 allows you to transfer the translations from the previous set of 
*.sdlxliff, SDL Edit (ITD) or Tradostag (TTX) bilingual documents to the new project files. 

https://doc.rws.com/TradosStudio2021/TranslatingAndReviewingQSG
https://doc.rws.com/TradosStudio2021/TranslatingAndReviewingQSG
http://docs.rws.com/TradosStudio2021
http://docs.rws.com/TradosStudio2021
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Note: Your license for Trados Studio may or may not include this feature. See the About Editions 
and Licensing topic in the Trados Studio 2021 Help for information about your license features. 

5.7 Why should you use PerfectMatch? 

There are two main scenarios when you can leverage previous translations by applying 
PerfectMatch. For a list of additional scenarios, see the Trados Studio 2021 Help. 

Pre-Project scenario 

At the start of a project, you can base a new project on an existing project that has been fully 
reviewed. This will use the translated documents from the previous project for PerfectMatch. 
This could be useful, for example, if you are starting translation on a technical manual for a 
second version of a product where the product is almost the same as the first version. 

Mid-Project scenario 

If you are part of the way through translating a project and you receive a new set of source files 
that have been slightly modified, you can use PerfectMatch to easily apply the work you have 
already translated to the new set of documents. This can be accomplished by creating a new 
project with the new set of files and basing it on the project you are in the middle of translating. 
PerfectMatch will then automatically apply all of your existing work to the new set of files. 

 
1. New project files 

2. Previously translated documents 

http://docs.sdl.com/TradosStudio2021
http://docs.sdl.com/TradosStudio2021
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Assume that the SamplePhotoPrinter.doc has a version 1 of the document that was fully 
translated and reviewed in a previous project. 

SamplePhotoPrinter-Version1.doc 

 
This means that all segments are translated and reviewed. 

In your current project, you have selected version 2 of this document which has some additional 
text that has been added for this release. 

SamplePhotoPrinter-Version2.doc 

About this task 

 

Since the document is primarily the same as the previous document, you can extract the 
translations from the previous document and transfer them to the new version of the 
document as PerfectMatches. 

Procedure 

1. On the PerfectMatch page, select the previous document to use for PerfectMatch: 

 Click Add and select Specific Previous Document from the drop-down list.  

 Select the previously translated version of the document. 

 The previously translated version of the sample document is not included in 
the Trados Studio sample documents. However, you can see the results of 
applying PerfectMatch on the next page. 
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Since the previous document had been fully translated and reviewed, any 
translations that are transferred to the new project file do not need any further 
translation or review. 

2. To indicate that no further work is needed on the transferred translations, select to 
Lock segments after matching. 

Selecting this option will transfer all of the translations to new document with the 
following displayed in the Segment Status column: 

  - Indicates that the match type is PerfectMatch. 

  - Indicates that the segment status is Signed off. This means that the 
translations need no further translation or review. 

  - Indicates the translations are locked. This avoids anyone accidentally 
editing them since no further work is needed. 

3. Return to the New Project wizard and click Next on the PerfectMatch page. 

 

Results of applying PerfectMatch 

 

5.8 Selecting tasks and task settings 

On the Project Preparation page, you select the preparation steps that you want to be 
performed on the files in the newly created project. 

The task sequence contains batch tasks that prepare your project files. For more information, 
see “Batch Task” on page 11. 
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Default task sequence  

Depending on which edition of Trados Studio you are using, a different task sequence is 
selected by default: 

 Prepare 

 Prepare without Project TM 

Both of these task sequences prepare the files for translation by converting them to the 
bilingual *.sdlxliff format, pre-translating them and analyzing them. The only difference is that 
the Prepare without ProjectTM does not create a project translation memory. 

Note: A project translation memory contains translations that have been taken from the main 
translation memories that you selected for a project. Only translations where there is a degree 
of match that at least meets the minimum match requirement you have specified will be 
retrieved into the project translation memory. 

Why use the Prepare task sequence? 

You may want to use this task sequence to create a project translation memory if you do not 
want translators updating the main translation memory during translation but still want to 
allow them to leverage translations from one document to another or from other translators 
working on the same project. 

About this task 
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Procedure 

1. If necessary, select the Prepare task sequence from the Task Sequence drop-down 
list and then click Next. 

The Batch Processing Settings page is displayed. On this page, you specify batch 
processing settings. These settings are applied when the tasks selected on the 
Project Preparation page are performed. 

 

The settings available are determined by the batch tasks you chose on the previous 
page. For example, Analyze Files is selected on the previous page and therefore is one 
of the options on the navigation tree on this page. 

2. Select the Project Translation Memories page. On this page you can specify if you 
want the project translation memory to be created as file-based on your computer 
or on a server that translators can connect to at the same time. 

3. Keep the default settings to create the project translation memory as file-based and 
click Finish. 

4. The Preparing Project page is displayed while your project is being created. Progress 
bars indicate what task the process has reached. 

5. When all of the tasks have been completed, click Close to close the New Project 
wizard. The project you created, Sample EN-DE, is automatically opened in Trados 
Studio and becomes the active project. 
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Active project 

You can have several projects listed in the Projects view at the same time. However, only one of 
these can be open in Trados Studio at any time and this project is known as the active project. 
When you created a project in the last exercise it automatically became the active project.  

 The name of the active project is displayed on the title bar of the application. 

 The files for the project are displayed in the Files view. 

 The reports that have been generated for that project are displayed in the Reports 
view. 

Translation file status 

Procedure 

Click the Files button in the navigation pane to display the Files view. 

1. All of the files that you added to the project are listed here. They all have a status of 
In Translation. 

2. Click on the different files and select the Confirmation Statistics tab at the bottom 
of the screen to see how many segments were translated during pre-translation. 
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5.9 Creating a cloud project 

You can also create translation projects directly in your cloud account to sync them 
automatically to your own, secure cloud space. You can create cloud projects either from Trados 
Studio or from a browser. Alternatively, convert local projects to cloud projects by saving them 
to cloud. For more information see the Save local projects to cloud topic in the Online Help. 

Pre-requisites for creating cloud projects 

With a Trados Live Essential subscription, you create your own cloud projects that you can then 
translate in the Editor view or in the Online Editor. This enables you to work on cloud projects 
using both your desktop as well as an online editing environment, depending on your needs and 
project flows. 

Before you create cloud projects, first onboard your account and create all the resources 
required for working with translation projects in the cloud. 

Sign in to your cloud account to onboard your account 

To work with cloud projects, make sure that your account has an active subscription for one of 
the following cloud offerings: 

 Trados Live Essential 

 Trados Live Team 

 Trados Enterprise (formerly RWS Language Cloud Translation Management) 

This guide details the workflow for creating cloud projects using a Trados Live Essential 
subscription. Trados Live Team and Trados Enterprise (formerly RWS Language Cloud 
Translation Management) subscriptions give you access to more complex workflows and more 
account resources. For more information, see Cloud offerings and subscriptions in the Trados 
Studio online Help. 

 

To sign in to your cloud account from Trados Studio, if you are not signed in already: 

3. Open Trados Studio. 

4. Select the   area from the upper-right hand corner. 

5. Go to the Log in tab. 

6. Enter your username and password, and click Log In. 

7. Click My Account on the Language Cloud Sign In page to also open your account 
in a browser. From here you can start onboarding your cloud account. 

You can also sign in to your account directly from a browser, by accessing the RWS ID webpage. 

  

Multiple accounts 

https://docs.sdl.com/TradosStudio2021/
https://docs.sdl.com/TradosStudio2021/CloudSubscriptions
https://languagecloud.sdl.com/lc/login
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Your cloud credentials can be linked to more than one cloud account. This happens when 
multiple project managers add you as a member of their account. When you sign in to RWS 
Language Cloud with your cloud credentials, Trados Studio shows all the cloud accounts that 
you are a member of. 

 

To filter out the projects available on your other accounts, enable Show projects for this 
account only. 

Different cloud accounts give you access to different resources. Depending on the subscription 
available for your selected account, you may be able to also activate Trados Studio before 
starting to work on cloud projects: 
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5.10 Prerequisite: Onboard your cloud account 

After logging into your cloud account, set up the structure of your account and prepare all the 
cloud resources required for creating cloud projects: project locations, customers, file type 
configurations, translation engines (translation memories, termbases, Machine Translation 
connections). 

1. Add customers 

Set up customers to define the structure or your cloud account. Cloud projects are always 
mapped to a customer in your account. For each customer that you add to your account, a 
dedicated customer location folder is automatically created. This enables you can organize the 
workspace in your account based on your customer folders. 

1. Go to the Dashboard tab in your cloud account and click Add Customers > Add. 

2. Select New Customer and enter the name of the customer that you want to add. 
Use the customer locations to map your cloud project to a folder in your cloud 
account. 

In this example, we are creating a new customer location called EU Commission > Samples. 
This is added in the default Root > Customers location as this is the only location available 
initially. You can then add subsequent customers under your other customer folders. 

For more information on working with users, see the Customers and customer users topic in 
the Trados Live Essential documentation. 

 

https://docs.rws.com/TradosLiveEssential
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2. Add other users 

With a Trados Live Essential subscription, you can add other Administrator users to your 
account. Each Administrator user has a separate space in the cloud account where they can 
create and work with their cloud projects individually. 

With a subscription for Trados Enterprise (formerly RWS Language Cloud Translation 
Management) or Trados Live Team, you can share projects and resources as well as add the 
following additional user types to your account: 

 Project Manager 

 Lead Project Manager 

 Customer Requester 

 Translator (a role dedicated to translators and reviewers) 

 Engineer 

 Terminologist 

Note: Only Administrator users have the permission to add other users to a cloud account. 
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To add additional users: 

1. Go to the Dashboard tab in your cloud account and click Add Users > Add. 

2. Click +New Member in the Members sub-tab. 

3. In the pop-up window, enter the valid email addresses of the users you want to 
invite and the account location where you want to add the user. With a Trados Live 
Essential subscription, you can only add users to the Administrators group in the 
Root location which enables them to create and work with their cloud projects 
individually. 

With a subscription for Trados Enterprise (formerly RWS Language Cloud 
Translation Management) or Trados Live Team, you can add the users to additional 
groups to create complex hierarchies in your account. 

Optionally, you can send a message along with the invitation in the Personal message box. 
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For more information on working with users, see the Customers and customer users topic in 
the Trados Live Essential documentation. 

 

 

https://docs.rws.com/TradosLiveEssential
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3. Configure resources 

Go to Resources tab in your cloud account and configure translation resources to use when 
creating cloud projects or project templates. These resources will be available when you 
translate the cloud project files in the Editor view or in the Online Editor. 

Tip: For initial onboarding, start configuring items in the Resources tab from right to left. This 
means you will define resources starting with the last option on the right, and ending with the 
Project Templates option. 

 

3.1 Add Neural MachineTranslation (NMT) engines 

Add NMT engines to your account to make them available for future cloud projects. NMT 
engines are used during automated translation tasks and interactive lookups when translating 
and reviewing in the Online Editor and in Trados Studio's Editor view. 

To link your cloud account to your Language Weaver account: 

1. Click on your initials in the top right corner of your browser and select Manage 
Account. 

2. Under Language Weaver, add the credentials of your Machine Translation account 
to bring your machine translation resources in your cloud account. 

3. Click Resources > NMT Models tab and check the resources in your Machine 
Translation account. You can then add these resources to new cloud projects or 
templates. 

In this example, we have linked a Language Weaver account with the following engines: 

 
For more information on configuring and using NMT models, see the Language Cloud MT topic 
in the Trados Live Essential documentation. 

https://translate.sdl.com/login
https://docs.rws.com/TradosLiveEssential
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3.2 Create Language Processing Rules 

Language processing rules contain information about the following elements in a TM: 
compounds treated as one word, segmentation rules and recognized tokens: Numbers, Dates & 
Times, Measurements, Variables, Abbreviations, Ordinal followers. 

When you create new cloud-based TMs, you can select a language processing rule to add to the 
new TM the settings stored in the rule. You can use the default language processing rule or 
create a custom one. Custom rules enable you to specify custom settings and formats for the 
items in the TM that are recognized as non-translatable items. 

To add a custom Language Processing Rule: 

1.  Go to your cloud account, Resources tab > Language Processing Rules > New 
Language Processing Rule. 

2. Specify a name, the location on your account where you want to add the rule and 
customize the settings for identifying and localizing placeables in your TMs. 

3. Click Create. 

In this exercise, we are using the default Language Processing Rule available in the account as 
this uses relevant language resources and settings for most TMs: 

 
For more information on configuring and using NMT models, see the Language Processing 
Rules topic in the Trados Live Essential documentation. 

3.3 Create cloud termbases 

Create termbase templates to easily apply the same settings to future cloud termbases. Cloud 
termbases can be created from scratch, from a template, or from an existing MultiTerm 
termbase definition. You can also import and export termbase entries or download the 
termbase definition to use it for creating termbase templates. 

Go to the Terminology tab and choose whether you want to create a new termbase or a new 
termbase template: 

1. Click Resources tab > Terminology > Termbases and click + NewTermbase. 

2. Fill in the details for the page wizard and click Create. 

In this example, we are creating a new termbase from an existing Trados Studio 
termbase definition (.XDT file) exported from MultiTerm Desktop: 

https://docs.rws.com/TradosLiveEssential
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3.  Select the new termbase and click Import. Upload tembase content from a .xml, 
.tbx , .xlsx , .csv file. In this example we are importing termbase entries from an XML 
file: 

 
For more information on configuring and using NMT models, see the Language Cloud 
termbases topic in the Trados Live Essential documentation. 

3.4 Create cloud translation memories 

 

1. Go to the Translation Memories tab and choose whether you want to create a new 
cloud TM or a new cloud field template: 

Create new Translation Memories to add to future cloud projects. You can access the cloud 
TMs when translating or reviewing cloud project files in the Online Editor and inTrados Studio's 
Editor view. 

https://docs.rws.com/TradosLiveEssential
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You can create TMs from scratch or import TM content from existing, local TMs. 

The structure of cloud TMs is based on language processing rules and field templates: text, list, 
date/time, numbers. 

Field templates enable you to work consistently across your TMs and create TMs that share 

the same fields faster. TM fields hold descriptive data for each translation unit (TU) in a TM. 

Cloud accounts with a Trados Live Essential subscription include a general default Field 
Template, default Language Processing Rule and Default File Type Configuration that you can 
use for all customers. Cloud accounts with Trados Live Team or Trados Enterprise (formerly 
RWS Language Cloud Translation Management) subscriptions include these default resources 
for each customer that you create. When creating cloud TMs, you can use these defaults 
resources as they are or you can customize to use custom TM settings. 

2. Enter the details of your new cloud TM, the Language Processing Rules and Field 
Template to apply to the new TM, and click Create. 

In this example, we are creating an English to German TM that uses default Field 
Template and the default Language Processing Rule. 

3. After creating the TM, you can are also import the translation units from an existing 
TM by selecting the newly created TM, and clicking Import. Browse to an .SDLTM, 
.TMX or .SDLXLIFF file, edit the general TM options and click Finish: 

 
For more information on configuring and using NMT models, see the Language Cloud TMs 
topic in the Trados Live Essential documentation. 

https://docs.rws.com/TradosLiveEssential
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3.5 Configure translation engines 

Create a translation engine that combines TMs, termbases and Machine Translation engines. A 
translation engine enables you reuse all these resources across projects without having to 
specify them for each new similar project. 

Configuring all resources from one central location instead of specifying each resource 
separately saves you time, especially if you work with translation projects that share similar 
subject fields. 

To create and configure a new translation engine: 

1. Go to the Resources tab > Translation Engines > + NewTranslation Engine. 

2. Enter the general details of your new engine, specify the location where you want to 
store the engine in your cloud account and the project languages to which the new 
engine can apply. 

Tip: Type ISO language codes to quickly add source and target language to your 
translation engine. For example, type de-de for German (Germany). 

3. Add the TMs and Machine Translation engines that will be included in your engine. 
In this example, we are adding the Sample termbase and Sample Printer TM created 
in the previous steps: 

 
For more information on configuring and using NMT models, see the Language Cloud 
Translation Engines topic in the Trados Live Essential documentation. 

 

 

https://docs.rws.com/TradosLiveEssential
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3.6 Create FileType configurations 

File type configurations specify which types of files in a cloud project can be processed for 
translation and how translatable content inside these files is extracted for translation.Your 
account includes a default configuration that extracts regular translatable content from most 
file types. 

If you plan to use custom file type settings for your cloud projects, edit the default file type 
configuration in your cloud account, or create new custom file type configurations. For example, 
you can create a custom configuration by editing the default one to also extract comments from 
PDF files. You can attach your custom configuration to future cloud projects to speed up project 
creation. 

If a cloud project includes file types that are not enabled in the configuration, these file types 
will not be processed for translation. 

If you have custom file types created inTrados Studio, you can import these here to leverage 
existing file type settings. 

To create a new file type configuration: 

1. Go to the Resources tab > FileType Configurations and enter the general details of 
your file type configuration. 

2. Select your newly created configuration and click Edit. 

3. Click on each file type in the configuration, and edit the available settings. If you are 
an expert user, click Advanced Settings to configure more file type properties. 

4. Click Save. 

 

For this exercise, we are using the existing, default file type configuration 

 
For more information on configuring and using NMT models, see the File Types topic in the 
Trados Live Essential documentation. 

 

3.7 Create project templates 

Project templates bring together a translation engine (termbase, TM, Automated Translation 
engine), a file type configuration and a set of project settings. Projects templates for accounts 
with a Trados Live Team subscription also include workflows. Projects templates for Trados 

https://docs.rws.com/TradosLiveEssential
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Enterprise (formerly RWS Language Cloud Translation Management) subscriptions also include 
workflows and pricing models. 

Create projects based on a project template to automatically populate the project creation 
wizard with all the resources and settings available in the template. The project templates in 
your cloud account are available when creating projects from Trados Studio or from a browser. 

To create a new cloud project template: 

1. Go to the Resources tab > Project Templates and click New Project Template. 

2. Enter the general details and update the Translation Engine and Settings page of 
the wizard, then click Create. 

In this example, we are creating a template that uses all the resources configured so far. This 
can be applied to future English to German projects to speed up project creation: 

 
For more information on configuring and using NMT models, see the Project Templates topic 
in the Trados Live Essential documentation. 

 

5.11 Creating cloud projects from Trados Studio 

You can create cloud projects both from Trados Studio and from a browser. You might prefer 
creating cloud projects from Trados Studio when you plan to start translating or reviewing in 
Studio's Editor view right away and you want to use a simpler workflow. 

To create cloud accounts, make sure you have already onboarded your cloud account as 
explained in the section Prerequisite: Onboard your cloud account. 

1. Select New Project > New Cloud Project or press Ctrl+Alt+N. Trados Studio displays 
the Create New Language Cloud Project on the General page. 

https://docs.rws.com/TradosLiveEssential
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2. Enter a name for your project. The maximum length for project names is 50 
characters. 

3. Select a date and time by which the project must be completed. 

4. In the Location field, select the folder in your cloud account where you want to 
store the project. For this exercise, this is the EU Commission > Legal created in the 
"Add Customer" section of this guide. 

5. Optionally, select a template available in the location that you have specified for 
your project above. 

6. From the File Type Configuration list, select an existing configuration available in 
the selected location. Custom configurations enables you to specify exactly the type 
of files that can be processed as translatable files, and the type of text that can be 
extracted from the files. 

In this example, we are using the Template for Sample Resources created in the 
previous section which automatically adds the configuration included in the 
template: 

 
7. Add the project files. Click Add Files to add individual files. To add a set of files, drag 

a folder or an archive. For *.sdlxliff files, the source and target languages are 
automatically detected when the files are added. 

8. In the Usage column, specify which files are Translatable and which ones should be 
used as Reference only. Trados Studio automatically identifies the files as 
Translatable or Reference, according to specifications of your selected file type 
configuration. 
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9. Specify one Source Language and one or more Target Languages for your project. 
The language fields are pre-populated with the default languages specified under 
File > Options > Editor > Languages. 

10. In the Description box, enter some relevant details about your project. The 
maximum description length is 200 characters. 

11. Click Next to go to the Translation Resources page and select a translation engine 
to use for your project. RWS Language Cloud translation engines include translation 
memories, termbases and Neural Machine Translation. 

12. Select an existing translation engine available in your cloud account. 

In this example, we are adding the sample engine created in the previous section. 
This automatically applies the translation resources and the language processing 
rule available in the engine. 

 
The resources available in the selected translation engine are not editable. However, you can 
add additional, local translation resources when you download the project in Trados Studio and 
go to Project Settings. 

13. Click Next to go to the Summary page of the wizard and consult the project details. 
If you are logged in as an Administrator, Project Manager or Lead Project Manager 
with a Trados Live Team or a Trados Enterprise (formerly RWS Language Cloud 
Translation Management) subscription, the wizard also displays the Workflow page. 
Administrators with a Trados Enterprise (formerly RWS Language Cloud Translation 
Management) subscription also see the Pricing Models page before the Summary 
page. 
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14. Select Finish to create and start the new cloud project. Trados Studio uploads the 
project to your cloud account and starts preparing the project files. The  
Notifications tab shows a We are preparing your cloud project message in, on the 
right-hand side of the screen. 

 

Monitor project preparation 

The processing of cloud project files is handled in the cloud. This frees all Trados Studio 
resources for any local projects you might be working on in parallel. 

Newly created cloud project are available in Trados Studio only after the RWS Language Cloud 
has finished pre-processing the files. To monitor project preparation from Trados Studio: 

1. In the  Notifications tab, go to the We are preparing your cloud project 
message displayed after you have finished creating the new cloud project. 

2. Click Open in Language Cloud in this notification to check the project preparation 
in the Stages tab. 

3. Click Refresh in the Stages tab to update the project status and check that the files 
have been pre-processed and have reached the first Translation, Linguistic Review 
or Implement Customer Review task in the workflow. With a Trados Live Essential 
subscription, the only manual task in the workflow is the Translation task: 
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When the files reach the Translation stage, Trados Studio displays the projects files in the Files 
view. The new project is also immediately available in the Projects tab of your cloud account. 

You can now start translate or review either in the Online Editor or in Trados Studio's Editor 
view. 

For more information, see the Translating and reviewing Quick Start Guide . 

 

5.12 Creating cloud projects from a browser 

To create a new cloud project from a browser: 

1. Once you are logged in into your account from a browser, click Projects > + New 
Project to display the cloud project creation wizard from the browser. 

2. Add the general project details: Name, Due date and an optional Description. 

In this example, we are creating a new project with the same cloud resources used in the 
project created previously from Trados Studio: 

 
3. Add the project files. RWS Language Cloud automatically identifies the files as 

Translatable or Reference, according to specifications of your selected file type 
configuration. In the Usage column, you can change which files are translatable and 
which ones should be used as reference only. 

4. Select the location in your cloud account where you want to save the new project. 

5. Select a project template to pre-fill the project settings and cloud resources from the 
template. 

6. Click Next to go to the Translation Engine page to add an engine if you do not have 
one specified in the project template. 

If you are logged in as an Administrator, Project Manager or Lead Project Manager 
with a Trados Live Team or a Trados Enterprise (formerly RWS Language Cloud 
Translation Management) subscription, the wizard also displays the Workflow page. 

https://docs.sdl.com/TradosStudio2021/TranslatingAndReviewingQSG
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Administrators with a Trados Enterprise (formerly RWS Language Cloud Translation 
Management) subscription also see the Pricing Models page before the Summary 
page. 

7. Click Create and Start to finalize creating the new project with default settings, or 
click Next to specify the TM and verification settings for your project. You can also 
change these project settings after creating the project. 

Most of these project settings can also be edited when opening the project in Trados 
Studio. However, Penalties, Filter Penalties, Field values and Verification settings for 
cloud projects are read-only in Trados Studio. These settings can only be edited 
when accessing your Cloud account from a browser, in the Settings > 
Configuration area of the selected project. 

For more information on configuring and using NMT models, see the Project creation topic in 
the Trados Live Essential documentation. 

5.13 Saving local projects to cloud 

Save your local projects and project packages to cloud to upgrade them with cloud capabilities 
such as automated translation workflows, access to the Online Editor, frequent back-ups and 
syncing across devices. You can also use your local TMs by saving them to cloud. For more 
information on how to save your local TMs to cloud, see Save TMs to Cloud. 

Before you begin 

Before you begin, make sure that you have an active subscription for one of the following cloud 
offerings: 

 Trados Enterprise  

 Trados Live Team 

 Trados Live Essential. 

About this task 

To save your local project to cloud: 

Procedure 

1. Select your project from the Projects view and click on  Save to Cloud on the 
ribbon. Alternatively, you can select your project, right-click on it and select Save to 
Cloud. This displays the Save to Cloud wizard. 

2. On the first page of the wizard, configure the following: 

 Choose a Project Name for your cloud project. By default, the wizard will automatically 
complete the field with the name of the local project, but you can overwrite it. 

 Under Due, choose the due date of the project. If the project already had a due date, 
the wizard will automatically complete the field with the due date of the local project, 
but you can change it to a new due date. 

https://docs.rws.com/TradosLiveEssential
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 In the Location field, select the folder in the cloud account where you want to save 
your project. If you are logged in with an Administrator account, you can also click New 
customer to create a new location in your cloud account. 

 Select one of the Translation Engines available on your cloud account. Translation 
engines include translation memories, termbases and Neural Machine Translation. 
Note that your Translation Engines need to contain at least one language pair present 
in your project, otherwise they will not show up in the list. 

 If you have a Trados Enterprise subscription, you can also set a Pricing Model. Pricing 
models determine price estimates for each project language and calculate additional 
costs. If you are logged in with an Administrator or Lead Project Manager you can also 
click + New Pricing model to go to your cloud account and add a new one. 

 Under Workflow, choose an existing workflow from your cloud account. If you are 
logged in with an Administrator, Project Manager or Lead Project Manager you can 
also click + New Workflow to go to your cloud account and add a new one. 

3. Click Next to go to the Summary page. Here you can review your specifications. 

4. Click Finish to complete the wizard and save your project to the cloud. Your project 
will be grayed out and disabled until the process is complete. You can check the 
progress in the Notifications tab. 

 

6 Working with packages 

6.1 Project package 

A project package is a single zipped file that contains all of the files that need to be sent to a 
project team member in order for them to commence work on the project. 

It can contain: 

 Project files: Bilingual SDL XLIFF files and reference files 

 The project translation memory 

 File-based termbases, translation memories and AutoSuggest dictionaries 

 Connection details for server-based translation memories, server-based termbases or 
automated translation providers  

  Project settings 

6.2 Return package 

A return package contains project files for which a specific manual task has been completed. For 
example, project files that have been translated or reviewed. It can also contain files for which 
further work needs to be completed. For example, a reviewer may want to return a translated file 
because of an incorrect translation which the translator needs to fix. 
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When you create a return package it only includes the project files and not the translation 
memory, termbases or AutoSuggest dictionaries. 

6.3 Recommended package use 

There are two recommendations about how you work with packages in your workflow: 

 Always create a package for every task you want to be completed. 

 Always create a return package for every task you have completed and send to the 
person who gave you the task. 

 

6.4 Creating a package for a local project 

After creating a local project, the next step is to create a project package. Then you can send it 
to a translator so that they can translate the files it contains and use the resources that you 
selected during project creation to assist the translation. 

About this task 

…Documents\Studio2021\TranslationMemories\SampleEN-DE.sdltm (This is the project you 
created in the last section.) 

Procedure 

1. Select the three files in the local project in the Files view and right-click and select 
Create Project Package from the shortcut menu. You can also select Create 
Project Package from on Home tab. 

2. The Create Project Package wizard is displayed on the Select Files page. Select Next 
to include all three files in the package. 

The Project Package Options page is displayed. On this page, specify where you want to save 
the project package and if you want to create one package or to split the files into multiple 
packages. 
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3. Leave the default selections on this page and select Next: 

 The package is saved to Documents/Studio2021/Projects by default.  

  One project package is created containing all three files. 

 If your project has more than one language, you can choose to create a package for every 
project language and then send each package to the appropriate translator. 

You can also further split a package by the number of words that have not yet been translated. 
This allows you to assign the work for one language pair to multiple translators. 

 

The Review Project Packages page is displayed. 
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4. Assign the work of translating these files to a user: 

 Select Users next to the AssignTo box. 

 Create a user called TomTranslator with a description of EN-DE Translator. 

 Select TomTranslator from the Assign To drop-down list. 

5. Since the files you are sending need to be translated, ensure that Translate is 
selected from the Task drop-down list. 

 If you were sending files for review, you can select the Review task or any custom tasks that 
you want to create. 

6. In the Comment box, enter the following instructions for TomTranslator: 

Please translate these files and then send them in a project package to Ralph 
Reviewer. When you receive the reviewed files in a return package, open the 
package in Trados Studio and then create a new return package to send to me 
(project manager). 

7. Select Next. 

8. The Additional Options page is displayed. On this page, specify other resources to 
be included in the package: 
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 Project Translation Memory: Leave the default selection, Create a new file-based 
project translation memory for every package. The new project translation memory 
contains information only relevant to the files in the package. 

  You might want to select this option if the contents of the package are small compared 
to the project itself. Including the entire project translation memory for a large project 
would create large packages. 

 File-based Resources: Select the AutoSuggest dictionaries check box and Termbases 
check box to include these resources from the project in the package. 

 Click Finish. 

Note: For more information about all of the options of this page, see the Trados Studio 2021 
Help. 

9. The Creating Packages page is displayed. On this page, the packages are created 
and you can choose to send the project packages by: 

 Email to the appropriate team members by selecting Send Packages by Email. 

 Another method such as placing it on an FTP site. Select OpenTarget Folder to 
open the folder where your return package is saved. 

10. Click Close. 

Assume that the package has now been sent to the translator. When the translator opens the 
package, all of the resources included are automatically opened during translation. 

6.5 Opening a return package 

Assume that the translator (Tom Translator) has completed the translation and that the 
reviewer (Ralph Reviewer) has approved all of the translations. You receive a return package 
from Tom Translator containing the translated and reviewed project files. 

Procedure 

To open the return package: 

1. Select Open Package on Home tab when you are in the Projects view. The Open 
Package wizard is displayed. 

2. Select the return package and click Open. The Open Package wizard opens on the 
Review Package Contents page. 

 You cannot import the return package content into the project that you have not created 
yourself. 

http://docs.sdl.com/TradosStudio2021
http://docs.sdl.com/TradosStudio2021
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3. Review the package details and select folders from the bottom left-hand pane to 

view the files within that folder in the bottom-right hand pane. 

4. Select Finish to import the package. The Importing Package page is displayed. 

5. When the import is complete, select Close. 

The corresponding project is updated with the completed manual task information 
in Trados Studio. 

6.6 Packages for cloud projects 

Cloud project files are synced to your cloud account whenever you save your changes in the 
Editor view. Because cloud projects are always online, you do not need to create packages for 
further work on the cloud projects. 

About this task 

However, you can download cloud project files to work offline, in the following workflows: 

 upload package offline in Trados Studio. This workflow is especially if you are working 
with Trados Studio 2017. This Trados Studio version that can open cloud projects but 
do not include the Open in Studio option. 

 upload offline cloud packages to a third-party CAT tool that support Trados Studio 
.SDLPPX packages. 

 publishing cloud packages on an Trados GroupShare server. 

To download cloud project packages from your cloud account: 

Procedure 
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1. Select your active cloud file tasks that you want to add to a package. 

2. Click More Actions > Download Package. 

 

 
3. Upload the downloaded .SDLPPX package into Trados Studio or a third-party CAT 

tool, translate the files, then create a return package to upload back to your cloud 
account. 

This will move the uploaded cloud project files to the Completed stage. 

 

7 Tracking project status 

Some reports are automatically generated during project creation. For example, the Analyze 
Files report is always created. Depending on which tasks you choose to perform pre-translation 
or apply PerfectMatch during project creation, the Pre-translated Files and Apply 
PerfectMatch reports are also generated. 

At any time during a project's lifecycle, you can use batch tasks to generate updated or new 
reports that give you information about the status of the translations in a project. You may want 
to do this after you have received completed work in a return package. 

The Translation Count report provides details about the status of the translations in a project. 
For example, the status may be Translated or Translation Approved. This is useful if you want 
to view the progress of the translation project. 

Tracking cloud project status 

When working with cloud projects, you can find detailed information on the overall status of 
your project, as well project-specific analytics from the Dashboard and Projects tab: 
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You can also check project progress in Trados Studio, in the Files view and File view windows: 
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7.1 Generating a report 

Generate the Translation Count report for the Sample EN-DE.sdlproj project you created: 

About this task 

 …Documents\Studio 2021\Projects\Sample EN-DE\Sample EN-DE.sdlproj 

Procedure 

1. In Projects view select Batch Tasks > Translation Count on the Home tab. 

2. On the Batch Tasks page of the Batch Processing wizard click Next. 

3. All files for the active project are listed on the Files page. Click Next. The Settings 
page is displayed. 

4. There are no settings that you need to specify to perform this batch task. Click 
Finish to generate the report. The Performing Tasks page is displayed. When the 
task is complete, the Translation Count report can be viewed in the Reports view. 

5. Display the report by closing the wizard and displaying the Reports view or by 
clicking Task Results and selecting to view the report from the Task Results dialog 
box. 

The report data is split into three parts: 

 Summary: This displays a summary of information, for example, the 
project name and how many files on which this report is based. 
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 Totals: This displays status information about all files on which the 
report is based. 

 File Details: This displays information per file. Since this project has 
three files, they each have a section indicating the status of their 
translations. 

 
 

 

8 Finalizing your project files 

Assume that all the files in the project have now been translated and reviewed. The next step is 
to finalize your files. To finalize files, perform the following tasks: 

 Update Main Translation Memories to update the English-German.sdltm translation 
memory that was added to your project. This does not update the project translation 
memory that was created when the project was created. 

 Generate Target Translations to convert the *.sdlxliff files back to their original 
formats and places them into the German language subfolder. 

…Documents\Studio 2021\Projects\Sample EN-DE\Sample EN-DE.sdlproj 
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8.1 Finalizing local project files 

To finalize the files in a local project: 

About this task 

...Documents\Studio 2021\Projects\Samples\SampleProject 

Procedure 

1. In Projects view select BatchTasks>Finalize from the Home tab. The Batch 
Processing wizard is displayed on the Batch Tasks page. 

 
2. Click Next. The Files page is displayed. All files for the active project are listed here. 
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3. Click Next. The Settings page is displayed. 

4. Select All Language Pairs > Batch Processing > Translation Memory Updates 
from the navigation tree. This page shows the status that the translations must have 
in order for them to be added to the main translation memory. By default, only 
translations that have a status of Translated, Translation Approved or Signed Off 
are added to the main translation memory. In the If target segments differ 
section, select how Trados Studio treats new translation units that have the same 
source segment as an existing translation unit. 

5. Assume that you only want translations that have been reviewed to be added to the 
translation memory. Clear the check box next to Translated. When the batch task is 
performed, only translations that have been reviewed and approved update the 
translation memory. 

6. Click Finish to update the main translation memory and generate the target 
translated files. The Performing tasks page is displayed.  

7.  Click Close when the tasks have finished. The files in the Files view have now been 
converted back to their original formats and are no longer listed as *.sdlxliff files. 
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8. Select a file in the Files view and right-click and select Explore Containing Folder 
from the shortcut menu. Your translated files are placed in the German language 
subfolder de-DE of your project and saved with their original file names. This is the 
same folder that also contains the *.sdlxliff bilingual files. 

Your project is now complete and the translated files can be given to the customer. 

8.2 Finalizing cloud project files 

Generate the target translated files to finalize cloud project files. The Update Main Translation 
Memories batch task is not necessary for cloud projects. This is because cloud TMs are updated 
in the background when you manually save your changes in Trados Studio and automatically, 
when you translate in the Online Editor. 

From Trados Studio 

1. Click Batch Tasks > Generate target files (cloud projects) from the ribbon in the 
Projects, Files or Editor view. 

From a browser 

1. Go to your cloud account and click the Projects tab. 

2. Select the project for which you want to download the translated files and click 
Open. 

3. Click Files tab > Download all. 

 

9 End of this Quick Start Guide 

Now you know how to create and manage projects in Trados Studio. For additional information 
about creating and managing projects in Trados Studio, see the Trados Studio 2021 Help. 

 

 

 

 

 

 

http://docs.sdl.com/TradosStudio2021
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10 Acknowledgements 

Trados Studio includes open source or similar third-party software. 

#ziplib 

#ziplib (SharpZipLib, formerly NZipLib) is a Zip, GZip, Tar and BZip2 library written 
entirely in C# for the .NET platform. It is implemented as an assembly (installable in the 
GAC), and thus can easily be incorporated into other projects (in any .NET language). 

Apache log4net 

The Apache log4net library is a tool to help the programmer output log statements to a 
variety of output targets. log4net is a port of the Apache log4j™ framework to the 
Microsoft® .NET runtime. 

Hunspell 

Hunspell is the spell checker of LibreOffice, OpenOffice.org, Mozilla Firefox 3 & 
Thunderbird, Google Chrome, and it is also used by proprietary software packages, like 
Mac OS X, InDesign, MemoQ, Opera and Trados Studio. 

ICU (International Components for Unicode)  

ICU is a mature, widely used set of C/C++ and Java libraries providing Unicode and 
Globalization support for software applications. ICU is widely portable and gives 
applications the same results on all platforms and between C/C++ and Java software. 

SafeNet Sentinel 

SafeNet's Sentinel software licensing products and software protection solutions 
provides software publishers control and visibility into how their applications are 
deployed and used. 

Spring.NET  

Spring.NET is an application framework that provides comprehensive infrastructural 
support for developing enterprise .NET applications. It allows you to remove incidental 
complexity when using the base class libraries makes best practices, such as test driven 
development, easy practices. 

WiX 

The WiX toolset builds Windows installation packages from XML source code. The tool-
set integrates seamlessly into build processes. 

Xerces-C++  

Xerces-C++ is a validating XML parser written in a portable subset of C++. 

 

 

 

 

http://icsharpcode.github.io/SharpZipLib/
http://logging.apache.org/log4net/
http://hunspell.github.io/
https://icu.unicode.org/
https://cpl.thalesgroup.com/
https://www.springframework.net/news.html
https://wixtoolset.org/
http://xerces.apache.org/xerces-c/
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About RWS 

RWS Holdings plc is the world’s leading provider of technology-enabled language, content management and intellectual property services. 
We help our clients to connect with and bring new ideas to people globally by communicating business critical content at scale and 
enabling the protection and realization of their innovations. 

Our vision is to help organizations interact effectively with people anywhere in the world by solving their language, content and market 
access challenges through our collective global intelligence, deep expertise, and smart technology. 

Clients include 90 of the globe’s top 100 brands, the top 10 pharmaceutical companies and approximately half of the top 20 patent filers 
worldwide. Our client base spans Europe, Asia Pacific, and North and South America across the technology, pharmaceutical, medical, legal, 
chemical, automotive, government and telecommunications sectors, which we serve from offices across five continents. 

Founded in 1958, RWS is headquartered in the UK and publicly listed on AIM, the London Stock Exchange regulated market (RWS.L). 

For further information, please visit: www.rws.com 

© All Rights Reserved. Information contained herein is deemed confidential and the proprietary information of RWS Group*.  
*RWS Group shall mean RWS Holdings PLC for and on behalf of its affiliates and subsidiaries. 
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